PDA

View Full Version : Mythbuntu: nothing much works



NautiusMaximus
December 20th, 2008, 03:44 PM
Hi All

I've just installed Mythbuntu on a nice new HTPC, and although I didn't expect for a minute that everything would "just work", I did think that perhaps a few things would work.

But pretty much nothing works.

It's installed OK, and I get menu options. I haven't yet tried connecting it to a TV cable, so I haven't tried the TV yet. But I can't get any sound, I can't get DVDs to play, the remote control doesn't work, I can't rip CDs, and I can't import pictures from a camera's memory stick.

I have managed to get a couple of things to work. I can get a weather forecast and news feeds. I can view a photo that I've already inserted into the file system while exited from MythTV and using the Ubuntu desktop. But that's about it.

So, I could try to troubleshoot all these things one at a time, and maybe that's what I'm going to have to do. But I can't help thinking I must have done something horribly wrong somewhere along the way: perhaps there is a hidden option where I need to untick a box marked "completely screw up your entire user experience", or something like that.

Is it possible that there's something really obvious I've missed? Where would I start looking for it?

Many thanks
NM

stevetv
December 20th, 2008, 11:54 PM
if you phrase your questions more specifically it will be easier for people to help you.

1. no idea about your sound problems.. if you're using simple anolgo sound, try googling your sound card and ubuntu.
2. for DVD's.. you need to activate the codecs in the control center. if you've already done that than let me know.
3. What remote do you have? did you select it in the install.

Have you read the manual on the wiki? and have you popped over to mythtv.org and checked out the upstream wiki.. they're good starts. No there isn't a checkbox labled completely screw my experience.

dsbw
December 21st, 2008, 01:45 AM
Heh. I know that feeling. It's easier to actually resolve issues by listing them in separate threads with details, though.

For example, for ripping and playing DVDs, you generally want to make sure you've got the codes installed. (Check out the Mythbuntu control center.) You may have already done that, but it's hard to tell from your description.

NautiusMaximus
December 21st, 2008, 09:34 AM
You're right of course that I need to go into more detail with the problems and post them in separate threads if I want help with them. But the point of this thread was not so much to start troubleshooting individual problems, but to get a feel for whether there might be a more serious underlying problem that I should tackle first.

But it sounds like it's actually quite common for a lot of things not to work on a fresh Mythbuntu installation and not necessarily anything to worry about too much. I just need to take each one at a time, RTFM for that problem, and then post back here with specifics of that problem if necessary. Then when I've got that problem working, move on to the next, and eventually I'll have everything working.

Is that a fair description of how it all works?

Thanks
NM

SyvanX
December 21st, 2008, 01:51 PM
I would agree that generally a few things don't work out of the box. The few times I've done a clean install I've usually spent a day getting things back up to speed. Lirc has always been a pain for me, but the mythbuntu 8.10 setup was nice, I just had to figure it out.

It sounds to me like your problems aren't too severe. The remote shouldn't be too bad as long as you're not also planning to run an IR blaster. I don't know what could be the problem with sound, my problem was always getting the cables in the correct order, also make sure it's mythtv that's having the sound problem and not the computer in general, I've had that problem too.

dsbw
December 22nd, 2008, 08:50 AM
Yes, NM, that's about right. There are legal, technical and preference issues that makes things "not work" out of the box.

Sometimes they're related issues, sometimes not. Generally, there's no reason to panic.

NautiusMaximus
December 22nd, 2008, 10:38 PM
Good to know. I've already got the sound working, and no doubt I'll get to the bottom of the other bits and pieces in due course.

Watch this space...