PDA

View Full Version : [ubuntu] ATI Graphics card problem



SINZAR
December 11th, 2008, 07:50 PM
I'm using an ATI Radeon 9200 Pro with Hardy Heron and I'm stuck with the limited resolution of 1024 x 768. I've been using google and the search function and come up with some topics that gave me a base to start with but I haven't gotten anywhere.

Here's my xorg.conf


Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection


and here's my lshw -C Display output


*-display:0 UNCLAIMED
description: VGA compatible controller
product: RV280 [Radeon 9200 PRO]
vendor: ATI Technologies Inc
physical id: 0
bus info: pci@0000:01:00.0
version: 01
width: 32 bits
clock: 66MHz
capabilities: vga_controller bus_master cap_list
configuration: latency=32 mingnt=8
*-display:1 UNCLAIMED
description: Display controller
product: RV280 [Radeon 9200 PRO] (Secondary)
vendor: ATI Technologies Inc
physical id: 0.1
bus info: pci@0000:01:00.1
version: 01
width: 32 bits
clock: 66MHz
capabilities: bus_master cap_list
configuration: latency=32 mingnt=8


The last thing I tried was running sudo dpkg-reconfigure xserver-xorg which didn't help. The only thing it changed was adding "UseFBDev" "true" to the xorg.conf. Previously under configured video device I had a blank line which is different from other peoples xorg.conf's with similar cards. I've tried changing it in the hidden Screens and Graphics option but 1024 x 768 is still the highest it will go.

I have the machine hooked up to my home theater system/lcd tv so the resolution I have isn't fitting as it stretches the video.

Titan8990
December 11th, 2008, 07:53 PM
Was there not option to select ATI in dpkg-reconfigure xerver-xorg?


The open source drivers is all you will have to work with as the proprietary ATI drivers don't support cards that old.

SINZAR
December 11th, 2008, 08:31 PM
There wasn't really any video options in the depkg-reconfigure xserver-xorg except for the first question which asked if I wanted the kernel to help out with something and I choose yes.

Titan8990
December 11th, 2008, 08:33 PM
It should be the next option after that. The default is Vesa.

SINZAR
December 11th, 2008, 11:59 PM
I went through and tried it again, but after the kernel question it moves on to keyboard questions. Nothing else relating to video set up.

SINZAR
December 12th, 2008, 03:48 PM
Any other suggestions?

overdrank
December 12th, 2008, 03:50 PM
Any other suggestions?

Hi have you tried using the command
gksu displayconfig-gtk and adjust there.

Mucho
December 12th, 2008, 03:54 PM
go to ATI site..
and download newest driver for your card and isntall that

SINZAR
December 13th, 2008, 03:14 AM
Hi have you tried using the command
gksu displayconfig-gtk and adjust there.

Tried it but with no luck.

After messing around with it some more I really messed things up. I reverted back to my original partially working xorg.conf so I'm back at square one.

If I can't get a solution here I'm going to have to resort to getting another video card or abandoning ubuntu for this project. I don't want to do either. I know other people have gotten this working so I don't see a reason why I can't either. Any other ideas?

tgalati4
December 13th, 2008, 05:00 AM
I didn't see a device section:

Section "Device"
BoardName "3D Rage Pro AGP 1X/2X"
Driver "ati"
Identifier "Device[0]"
Option "AccelMethod" "XAA"
Option "XaaNoPixmapCache" "on"
Screen 0
VendorName "ATI"
EndSection

Of course, replace "ati" with "radeon"

overdrank
December 13th, 2008, 05:05 AM
Tried it but with no luck.

After messing around with it some more I really messed things up. I reverted back to my original partially working xorg.conf so I'm back at square one.

If I can't get a solution here I'm going to have to resort to getting another video card or abandoning ubuntu for this project. I don't want to do either. I know other people have gotten this working so I don't see a reason why I can't either. Any other ideas?

There is also the xfix option when booting into recovery mode. This can correct graphics issues

SINZAR
December 13th, 2008, 11:38 PM
I didn't see a device section:

Section "Device"
BoardName "3D Rage Pro AGP 1X/2X"
Driver "ati"
Identifier "Device[0]"
Option "AccelMethod" "XAA"
Option "XaaNoPixmapCache" "on"
Screen 0
VendorName "ATI"
EndSection

Of course, replace "ati" with "radeon"

I tried adding it in but it didn't seem to have any effect after restart.

b0b138
December 14th, 2008, 05:54 AM
Assuming everything works correctly booted from the live cd, copy the xorg.conf from the live section to your install.

SINZAR
December 14th, 2008, 09:02 PM
Good thinking I'll have to give that a try