PDA

View Full Version : [ubuntu] Different Backgrounds on Different Workspaces



bbright20
December 11th, 2008, 03:20 AM
First off I am loving Ubuntu and everything that you can do with it! I currently have 4 workspaces set up and I am trying to use a different background for each space. I have searched and read several threads and have had no luck.
I also tried this http://linuxowns.wordpress.com/2008/06/16/guide-to-customizing-ubuntus-look-and-feel/#1
Which I had no luck. I was wondering if anybody could point me in the right direction. Thanks in advance!

jimmy the saint
December 11th, 2008, 04:03 AM
Just did a little research for you.
I searched for "multiple wallpapers compiz" It turns out that compiz supports this feature. I then tried it. It failed.

I looked at a few more search results. It turns out that compiz applies multiple wallpapers (if told) but nautilus (which controls the desktop) puts it's wallpaper on top. There is currently no (easy) way to fix this (that I found).

One solution that would probably work, if you are willing to the do the work, would be to pick your wallpapers and join them in the gimp so that they are one big wallpaper. place the resulting image as your wallpaper and center it.

bbright20
December 11th, 2008, 04:08 AM
Thanks for all the help!

fubbleskag
December 11th, 2008, 04:35 AM
you can tell nautilus to stop drawing it's own desktop - the downside is you'll no longer see any desktop icons. if you can live with that, go into gconf-editor and browse to apps/nautilus/preferences and uncheck "show_desktop" (should not require a restart of X)

bbright20
December 11th, 2008, 04:40 AM
you can tell nautilus to stop drawing it's own desktop - the downside is you'll no longer see any desktop icons. if you can live with that, go into gconf-editor and browse to apps/nautilus/preferences and uncheck "show_desktop" (should not require a restart of X)

I have tried that before, but I have a cube set up as a sphere and when I uncheck "show_desktop" it changes my cube back to a square. And does not allow me to change the deformations. Any suggestions on why that happens? Thanks.

fubbleskag
December 11th, 2008, 05:01 AM
I have tried that before, but I have a cube set up as a sphere and when I uncheck "show_desktop" it changes my cube back to a square. And does not allow me to change the deformations. Any suggestions on why that happens? Thanks.hmm, strange. I just enabled sphere and it works fine for me with unique wallpapers. maybe try changing the order you make the changes (shouldn't make a difference, but what can it hurt to try)?

bbright20
December 11th, 2008, 06:25 PM
hmm, strange. I just enabled sphere and it works fine for me with unique wallpapers. maybe try changing the order you make the changes (shouldn't make a difference, but what can it hurt to try)?

I have tried it multiply ways and have had no luck.(I think my computer is possessed sometimes). I will just have to stick with this for now. :( Oh well, Ubuntu is still awesome. Thanks for all the help!

bapoumba
December 11th, 2008, 11:17 PM
http://forum.compiz-fusion.org/showthread.php?t=6199

And if you want to follow or input in the bug report:
http://bugzilla.gnome.org/show_bug.cgi?id=444320

feisty john
December 12th, 2008, 12:08 AM
KDE allows you to set different wallpapers for different workspaces. At least, KDE 3.5 does; I didn't try it when I was using KDE 4.

binbash
December 12th, 2008, 12:09 AM
KDE allows you to set different wallpapers for different workspaces. At least, KDE 3.5 does; I didn't try it when I was using KDE 4.

Also Kde4