PDA

View Full Version : [all variants] Where to configure ntpdate / ntp.conf missing



betnexrel
December 7th, 2008, 03:53 PM
I'd like to configure the timeservers for ntpdate or disable ntpdate without removing the package (e.g. to invoke ntpdate manually)

In /etc/defaults/ntpdate it says it uses /etc/ntp.conf but this file is missing.

The system clock is apparently set automatically because it's quite accurate...does anyone know where the config files are?



Release: Kubuntu 8.10

iponeverything
December 7th, 2008, 04:55 PM
sudo apt-get install ntp

betnexrel
December 7th, 2008, 06:30 PM
thx, ok, that would provide an ntp.conf file
but I don't want to install a daemon. As I said, automatic synchronisation seems to work already, without ntp being installed, I just can't figure out from which file(s) the timeserver(s) and the frequency of the queries are taken.

betnexrel
December 7th, 2008, 06:41 PM
Or am I totally wrong and the default installation of (K)Ubuntu _doesn't_ connect to ntp servers? (and the accuracy of the clock is chance)

Dr Small
December 7th, 2008, 07:28 PM
Or am I totally wrong and the default installation of (K)Ubuntu _doesn't_ connect to ntp servers? (and the accuracy of the clock is chance)
That's probably so.
You need the NTP daemon to sync your clock with the timeservers. Having it run as a daemon does not mean it is acting as a server, unless you edit the config file and change listen to *

The config file should be here:

/etc/openntpd/ntpd.conf

betnexrel
December 7th, 2008, 09:31 PM
I've tested it now by setting the clock to the wrong time, rebooted and the time was correct again. A simple

ntpdate <server>

in a script somewhere would be enough. The package ntp doesn't have to be installed, although, according to the manpage of ntpdate, the daemon is the better solution because of better algorithms for syncing with several servers.

but my issue was rather to keep control over internet connections generally.

A

grep -iR ntpdate /etc

yields some results but they depend on variables and I don't know if and when the scripts are executed, takes more knowledge/time

it could also be in KDE.'set date & time automatically' was unchecked in System Settings, but since KDE4 is still very new, it might be ignored.