PDA

View Full Version : [ubuntu] [SOLVED] yet another keyboard layout problem



baytuni
December 4th, 2008, 08:39 PM
I've been trying to use ubuntu nearly for 3 three years. Since back then turkish q layout has been a problem with ubuntu. I do not understand why this problem hasn't been fixed yet. For every new version of ubuntu since then I managed to solve the problem by ubuntuforums.I am again trying to migrate to ubuntu. But this time no help from the forums. I could not find any posts related with this issue.Anyway the problem is: despite I adjusted the keyboard as turkish-q in the beginning of installation and after installation. The layout is still standard us. Keyboard preferences says it is tr-q but in Xorg.conf there is no trace of keyboard layout. What should I do thanks,

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

baytuni
December 4th, 2008, 10:08 PM
solved the problem. It turned out that Turkish Alt-Q was not the one that I look for. I took a close look to the map and I figured out that Turkish Q (with dead keys) was the one. ı removed alt+q and put that one. Also ı added Turkish as a language. So everything works now.

bapoumba
December 4th, 2008, 10:49 PM
Deleted one duplicate thread and marked this one as solved (you have the option in the thread tools menu).